Cấu hình FTTH – PPPoE trên thiết bị router Cisco

Hướng dẫn này giúp các bạn cấu hình FTTH – PPPoE trên thiết bị router Cisco. Ngoài việc cấu hình PPPoE, hướng dẫn này cũng giúp bạn biết cách public 1 dịch vụ từ mạng LAN ra ngoài Internet.

Để cấu hình FTTH – PPPoE trên thiết bị router Cisco, chúng ta cần chuẩn bị các thông tin sau:

– Username nhà mạng cung cấp, ví dụ: ftth_myUsername
– Password nhà mạng cung cấp, ví dụ: ftth_myPassowrd

Chú ý, đối với nhà mạng FPT, ngoài username, password của PPPoE, nhà mạng FPT còn chứng thực thêm MAC address của Khách hàng. Do đó, sau khi cấu hình xong, bạn phải điện thoại nhờ FPT cập nhật địa chỉ MAC trên hệ thống của họ.

Các bước thực hiện:

– Định nghĩa Interface LAN
– Định nghĩa Interface WAN
– Định nghĩa Dialer Interface, dùng để kết nối PPPoE đến nhà mạng
– Định nghĩa NAT để người dùng trong mạng LAN có thể truy cập Internet
– Định nghĩa IP routing
– Định nghĩa static NAT để public dịch vụ Web trong mạng LAN ra ngoài Internet.

Sau đây là các bước thực hiện tuần tự:

CISCO(config)# interface GigabitEthernet0/0
CISCO(config-if)#description #LAN Interface#
CISCO(config-if)#ip address 192.168.1.1
CISCO(config-if)#no shutdown
CISCO(config-if)#ip nat inside

CISCO(config)# interface GigabitEthernet0/1
CISCO(config-if)#description #WAN Interface#
CISCO(config-if)#no ip address
CISCO(config-if)#pppoe enable group global
CISCO(config-if)#pppoe-client dial-pool-number 1
CISCO(config-if)#no shutdown

CISCO(config)# interface dialer 1
CISCO(config-if)#description #Dialer interface#
CISCO(config-if)#ip mtu 1492
CISCO(config-if)# dialer pool 1
CISCO(config-if)# encapsulation ppp
CISCO(config-if)# ip address negotiated
CISCO(config-if)#ip nat outside
CISCO(config-if)#ppp pap sent-username ftth_myUsername password 0 ftth_myPassword

CISCO(config)#ip nat inside source list 100 interface Dialer1 overload
CISCO(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any
CISCO(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1

CISCO(config)#ip nat inside source static tcp 192.168.1.100 80 interface Dialer 1 80

Bên dưới là các lệnh dùng để troubleshooting cấu hinh PPPoE, NAT và tài liệu tham khảo:

CISCO(config)#show ip interface brief
CISCO(config)#show ip nat translation
CISCO(config)#debug ppp authentication

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

Cảm ơn quý khách đã đặt hàng - Liên hệ với kinh doanh để được giá tốt nhất - Hotline : 0989 642 293 Bỏ qua